iPad Air 2 – wanna upgrade?

Comments Off on iPad Air 2 – wanna upgrade?

The iPad Air 2 is fresh on the market, so people are starting to ask me if they should trash their 1 (or even their original iPad).

Zibreg has this to say: http://www.idownloadblog.com/2014/10/16/ipad-air-2-vs-ipad-mini-3/

Fully laminated Retina display, Antireflective screen coating, Thinner, Faster, better Eyes, Burst mode pics, slo-mo video (120fps), Faster wifi, and a Barometer.

Often bypassed is the mention of “Apple SIM,” a nano SIM card that allows the cellular models to switch between multiple mobile carriers without changing the actual card (link).

Yosemite Upgrade VERY SLOW – frozen ?

Comments Off on Yosemite Upgrade VERY SLOW – frozen ?

Upgrading to OS X 10.10, from 10.9.5., is not as smooth as it could be. In the end, we booted the laptop (our test subject)(with encrypted SSD drive) in target-mode (through Thunderbolt) and ran the installer on the ‘external’ drive. After slowing to a crawl (again) the machine did ultimately complete successfully.

The initial steps preceding that were an upgrade that slowed to a crawl at the 99% point of the progress bar, and then seemed to freeze. Ultimately the machine went dark (crashed) and on booting, froze at the login screen. Once connected in target mode, we saw the leftovers of the failed upgrade.

This article may interest some: https://jimlindley.com/blog/yosemite-upgrade-homebrew-tips/

And remember that you can hit CTL-L during the install to track progress.

/shawn
Notes2self:
1. For the Munki rollout, pkg creation is here: http://managingosx.wordpress.com/2014/10/17/createosxinstallpkg-and-yosemite/
2. See Charles’s article on Profiles in Yosemite: http://krypted.com/mac-security/using-the-profiles-command-in-yosemite/
3. Read his share on enabling ARD & ssh: http://krypted.com/mac-security/configure-ssh-ard-and-snmp-in-os-x-yosemite-server/
4. Yosemite VolumePurchasingTokens : http://krypted.com/mac-security/add-your-vpp-token-to-profile-manager-running-on-yosemite-os-x-server/
5. Recovering from trashed certificates and configuration settings after a failed upgrade to Yosemite server: http://krypted.com/mac-os-x-server/reset-the-server-app-in-yosemite-server/
6. New ‘alert’ options in Yosemite server: http://krypted.com/mac-os-x/configure-alerts-in-os-x-yosemite-server/
7. Books on Yosemite by the Senior Editor of TidBITS and a Senior Contributor to Macworld: http://krypted.com/articles-and-books/three-new-take-control-books-titles-on-yosemite/
8. Proxying AppleSoftwareUpdates from Yosemite server: http://krypted.com/mac-security/using-the-software-update-service-in-yosemite-server/

Also.. WinClone, PushDiagnostics (and GeoHopper! think ProximityScripting) are all Yosemite ready (link).

Performance tweaks for OS X

Comments Off on Performance tweaks for OS X

My Macs boot fast, but then progressively slow down. Web browsers seem to have the biggest impact (burning CPU and chewing memory with Flash animations or JavaScript) but Microsoft Word & Excel can slow the CPU to a crawl. I’d like more control of which apps are allowed to ‘go dark (in the background) but continue working or not.

“App Tamer”, a utility that improves efficiency of CPU use and extends battery life, may soon become my ‘Go-To’ utility app.

For other ways to speed up your mac, check out my older article:

DropBox alternatives for Swiss Users – OS X

Comments Off on DropBox alternatives for Swiss Users – OS X

Many people use DropBox, for many excellent reasons.
idem. for other public cloud-drives like GoogleDrive, Amazon, OneDrive.

Remember that “dropbox-style syncing” hard to implement. Hiding the complexity from their users to the point at which nobody knows there even is any complexity, is amazing.

Some of my Mac-friends want an alternate security-choice more resistant to the failures of public-server-based Cloud-storage in our post-Snowden era of stolen-credentials, hacked accounts, flawed security, nude photos of dozens of celebrities, and government authorised snooping. They’re not totally confident that their encrypted virtual drive (thanks DiskUtility) will resist an HPC decryption attempt. Outside of those concerns are other friends wish for mobile access to +500GB of their own data without breaking their wallet.

  • OwnCloud – Unlimited data via your own server (or use SWITCHdrive).
        • Allows ‘undelete’, External storage integration (DropBox, Swift, FTPs, GoogleDocs, S3 and external WebDAV servers).
        • Supports useful plugins (e.g., tracking GeoIP logins to your directories).
        • UseCases: a) 400GB all synced between home and work. b) 2TB of music you want to play at home and while in your favourite Internet Café.
        • Blog – https://owncloud.com/blog/
        • NOK: Syncs can fail over completely and fails, or get confused and create a copy of every single file with “conflict” appended to the file name. These due to (??) evolving implementation code structure and newly-introduced frameworks and APIs.

     

  • SWITCHdrive (OwnCloud Instance)https://drive.switch.ch – 25GB of DropBox-like storage
    EPFL participants (Swiss Federal Institute of Technology) can have their cloud data stored on Swiss soil (contrary to Dropbox , Google Drive ou OneDrive). The folder-sharing model is NOT as nice as DropBox.
    This is just instance of OwnCloud (you can use the OwnCloud clients with it rather than the SwitchDrive client).
    Also think about SWITCHfilesender – http://help.switch.ch/fr/filesender/
    [M.Nguib] : “toutes les données uploadées sur SWITCHDrive sont enregistrées dans des centres de stockage situés en territoire suisse (à Lausanne et à Zurich). De ce fait, le traitement de vos données sera fait en accord avec les lois helvétiques. C’est-à-dire que vos données ne seront pas utilisées sans autorisation (comme le fait Dropbox) et qu’elles ne sont pas sous la loupe du projet PRISM (comme le sont OneDrive de Microsoft, Google Drive, Apple ou Facebook. Révélé par The Guardian du 12 juillet 2013) “.
  • Wualahttp://wuala.com/en
    This used to be free, but no longer is.
    Data is stored in Switzerland (Europe) and not the USA. It is encrypted on the client-side so not event the swiss company can see it’s contents. It the swiss government wants access to it, swiss citizens have recourse to oppose such access contrary to data stored on the other side of the ocean.
  • PydIO (aka AjaXplorer)
  • BTSync : eur100/yr

 

Fixing your MAC/Apple hardware

Comments Off on Fixing your MAC/Apple hardware

I help many people fix their Macs. Beyond the software problems and configuration problems there are a few easily solved hardware issues :

  • Trackpad no longer ‘clicks’ – it seems ‘stuck’ in clickmode.Solution: adjust the set screw located on the underside of the trackpad.
    Here’s how: If you don’t care about voiding your warranty (AppleCare), start by finding 3 screwdrivers (Philipps 00, TriWing, and a T-6 Hex). Remove the back of your MacBook Pro (10 screws). Then unscrew those holding the battery. Unplug the battery and remove it. Finally, slightly tighten (sometimes loosening is a better option) the screw on the trackpad.
    The problem may have come from battery swelling.

Hostnames, IPs, DHCP on my Macs – OS X

Comments Off on Hostnames, IPs, DHCP on my Macs – OS X

Here are a few quick reminders of network related things for my new mac installations.

  • The shell and the hostname utility disagree with that shown in SystemPreferences>Sharing. This problem also rears its head when using ARD and seeing a misreported mac client name.
    SOLUTION: Configure reverse-DNS lookup to return the correct hostname:

    sudo scutil --set ComputerName "newname"
    sudo scutil --set LocalHostName "newname"
    sudo scutil --set HostName "newname"
    dscacheutil -flushcache

    now restart

‘Running Package Scripts’ freezes

Comments Off on ‘Running Package Scripts’ freezes

 “Running Package Scripts” stays forever at the same state, when updating or when installing on 10.9.5 OS X Mavericks.

Some people encounter this with updating Safari (Software update). I first encountered this while trying to install Adobe Illustrator and Adobe Photoshop. I noticed that the Software update had stalled on the Safari update.. could my problem be related?

  • boot in recovery mode and fix any disk related or permission errors (Onyx had reported that my disk was fine, so I didn’t do this).
  • delete the contents of /Library/Updates (kudos to Jonathan for this, from here) – this fixed the stalled Safari update. Once the Safari update finished, the Adobe installs carried on fine (but slow)(be patient!) – THIS SEEMS TO BE WHAT WORKED FOR ME.
  • ensure there isn’t a headless Safari process running: ps auwwx | grep Safari
  • be patient – The message says ‘Install time remaining: About 2 minutes” but it took 10min before the progress-bar unstalled and carried on.
  • unplug external hard drives first before going into library updates folder
  • disable Time Machine (System Preferences) during the update/install
  • re-run Software Update

 

 

 

wget on OS X – 10.9

Comments Off on wget on OS X – 10.9

  1. xcode-select --install
  2. curl -O http://ftp.gnu.org/gnu/wget/wget-1.14.tar.gz
  3. tar -zxvf wget-1.14.tar.gz
  4. cd wget-1.14/
  5. ./configure --with-ssl=openssl; make; sudo make install

 

Configuration favs for OS X Clients

Comments Off on Configuration favs for OS X Clients

I enjoy using these tweaks to my OS X client macs:
(thanks go to Paul for all of these).

  • defaults write com.apple.dock persistent-apps -array-add '{"tile-type"="spacer-tile";}' ; killall Dock
    Places a spacer icon in the dock
  • defaults write com.apple.Dock showhidden -bool YES; killall Dock
    Makes hidden App icons Translucent in the dock
  • defaults write com.apple.mail AddressesIncludeNameOnPasteboard -bool false
    Makes copying email address stick to that, rather than adding names.
  • defaults write com.apple.finder QLEnableTextSelection -bool TRUE;killall Finder
    Allow text-selection from Quick-look.
  • defaults write com.apple.finder CreateDesktop -bool false; killall Finder
    Make all icons on the desktop invisible (they can still be seen in the Desktop/ folder).
  • sudo defaults write /Library/Preferences/com.apple.loginwindow AdminHostInfo HostName
    Set system-info to show on the login screen.
  • chflags nohidden ~/Library/
    Stop hiding the Library folder.

  • Enable ADMIN access through the Users’ screensaver lock:
    Edit/etc/pam.d/screensaver : comment out the line mentioning pam_group.so no_warn deny

See also: Terminal tricks on OS X. http://furbo.org/2014/09/03/the-terminal/
Think too: GeekTool, NerdTool, and Übersicht.

Munki and AutoPkg SURVIVAL TIPS – OS X

Comments Off on Munki and AutoPkg SURVIVAL TIPS – OS X

I love Munki and AutoPkg and you should too, but there are a few ‘gotchas’. Here’s what I’ve had to deal with:

  • Your software is up-to-date… but it’s not
    ie. You notice that your automated autopkg-wrapper.sh (thanks Sean) triggered by launchctl, brought in TextMate2-2.0-alpha.9561 (thanks to Graham‘s  ‘TextMate2.munki’  mentioned in your recipelist file). You happily noted the version show up in the testing manifest (which is watching the testing catalog). But ManagedSoftwareUpdate on your client mac just isn’t picking it up, insisting that there are no updates.
    WHAT WORKED FOR ME: In MunkiAdmin (thanks Hannes) click on ‘packages’ and double-click on TextMate 2. Change the name, and display name to ‘TextMate2’. Change the version to 2.09561 removing the word alpha, and any other non-numerics.

  • The app is in the manifest… but doesn’t get installed on the client.
    ie. Your other 99 Mac OS 10.9.4 clients successfully received Papers 3.. but that one pesky Mac client that remains (also 10.9.4) just refuses to see that it is behind the times, and stuck at Papers 2.
    – work in progress –

    • ensure your ClientIdentifier is as you expect:
      defaults read /Library/Preferences/ManagedInstalls
    • idem for SoftwareRepoURL
    • have a look to see if it appears in that client’s file /Library/Managed Installs/manifests, and catalogs
    • grep for Papers3 in /Library/Managed Installs/Logs to see if ManagedSoftwareUpdate thinks it is already installed. AHA!… This is the case.
    • determine how to tell ManagedSoftwareUpdate that it is NOT installed.
  • ERROR: Error: “hdiutil: attach failed – Device not configured”
    ie. I saw this for com.github.jleggat.autopkg-recipes.AppCleaner.munki.
    Try debugging by doing this in a shell :
    hdiutil attach /Volumes/DATA/Autopkg/Cache/com.github.jleggat.autopkg-recipes.AppCleaner.munki/AppCleaner.dmg

    For me, that successfully mounted the volume.
    WHAT WORKED FOR ME:  Remove the kernel cache (kudos to David for solving this one):

    sudo launchctl unload /System/Library/LaunchDaemons/com.apple.kextd.plist
    sudo rm /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache
    sudo launchctl load /System/Library/LaunchDaemons/com.apple.kextd.plist

    Sadly, that only solves the problem temporarily for me. The problem comes back in the next run of autopkg-wrapper.sh 🙁

Enjoy.

-shawn

p.s. Look for more information here:

  • munki – Getting Started – link
  • autopkg – Getting Started – link
    autopkg recipes – link

Older Entries Newer Entries